Настройка L2TP на MikroTik (Beeline)

 1. Подключить кабель к компьютеру, затем не создавая соединение сделать в командной строке - nslookup tp.internet.beeline.ru и записать    полученный адрес.

2. Подключить роутер, включить его и принять дефолтную конфигурацию.

3. Запустить Winbox, IP - DNS и записать два уже полученных динамических DNS.

4. Открыть терминал (New Terminal) и выполнить /ip route print detail. Видим в 2 и далее маршрутах gateway=10.XX.XX.1. Запоминаем его.

5. Открыть терминал (New Terminal) снова и исполнить этот скрипт!!!

 Предварительно XXXX заменить на свои Логин и Пароль. А также изменить полученный адрес из пункта 1 и ДНС из пункта 3 c нулями в место 4-ого диапазона, как и гейт полученный из пункта 4.

/ppp profile
add name=Beeline remote-address=192.168.255.254 use-compression=no use-encryption=no use-vj-compression=no
/interface l2tp-client
add add-default-route=yes allow=chap connect-to=tp.internet.beeline.ru disabled=no max-mru=1500 max-mtu=1460 name=Beeline password=XXXXXX profile=Beeline user=XXXXXX
/ip dhcp-client
add default-route-distance=2 dhcp-options=hostname,clientid disabled=no interface=ether1-gateway
/ip firewall nat
add action=masquerade chain=srcnat out-interface=Beeline
/ip route
add comment="Beeline VPN server subnet" distance=1 dst-address=XX.XXX.XXX.0/24 gateway=10.XX.XX.1
add comment="Beeline DNS server subnet" distance=1 dst-address=XX.XXX.XXX.0/24 gateway=10.XX.XX.1
add comment="Beeline DNS server subnet" distance=1 dst-address=XX.XXX.XXX.0/24 gateway=10.XX.XX.1

На этом этапе всё.
Если интернет не работает, то исполняем в терминале еще три строчки.

 /ip firewall mangle
add action=change-mss chain=forward in-interface=Beeline new-mss=1420 protocol=tcp tcp-flags=syn tcp-mss=1421-65535
add action=change-mss chain=forward new-mss=1420 out-interface=Beeline protocol=tcp tcp-flags=syn tcp-mss=1421-65535